Liberum Help Desk
The free, open source solution for the web-based help desk.

Migrating to server 2008

rated by 0 users
Answered (Verified) This post has 1 verified answer | 4 Replies | 1 Follower

Top 75 Contributor
4 Posts
brianf51 posted on 10-19-2011 9:47 AM

Has anyone successfully done a migration of their system on to Server 2008 yet.?   I have had Liberum running for years on Windows 2000 servers with the data on Sql server.

I now want to move the system off the 2000 box onto a 2008 one.  The setup seems to work as I've set the IIS7 up to feed ASP as well as the native ASP.net.

When I installed the system and run the setup.asp that part works OK but when I follow the link to setup the Language string or any other which calls the #include files all I get is a Internal Server error 500 returned.

I'm assuming it's something simple so does anyone recognize this?

Brian

Answered (Verified) Verified Answer

Top 75 Contributor
4 Posts
Verified by brianf51

Got it sorted. 

The main problem is ensuring that IIS7 is setup up to allow parent paths ie (../../admin.asp etc)  You can set this up in the IIS admin and check on technet for IIS, parent paths

All Replies

Top 75 Contributor
4 Posts

OK lets put this another way.  If I pick up a working system from a windows 2000 server and put it either on a win2003 or win2008 server I get immediate error 500, please does this ring any bells with anyone?

Not Ranked
1 Posts

How did you perform your migration? I had migrated mine from 2003 to 2008 with no problems. 500 error is too generic to pinpoint an exact fault.

Do you have other error messages or symtoms that you spotted?

Top 75 Contributor
4 Posts

Hi Kenny and thanks for getting back to me.  Would have thought someone would have seen this before.  It turns out I've made progress with this in the last few minutes.

Apart from the obvious fact that IIS 7 & 6 for that matter do not install ASP by default there now seems to be other things to. I have found that also by default using parent paths is turned off.  So using <!--  #include file = "../public.asp" --> will no longer work unless you go into the IIS server and specifically turn on parent pathing. See http://learn.iis.net/page.aspx/566/classic-asp-parent-paths-are-disabled-by-default/

Got it working on IIS6 but not 7 yet

Brian

 

Top 75 Contributor
4 Posts
Verified by brianf51

Got it sorted. 

The main problem is ensuring that IIS7 is setup up to allow parent paths ie (../../admin.asp etc)  You can set this up in the IIS admin and check on technet for IIS, parent paths

Page 1 of 1 (5 items) | RSS
Copyright © Doug Luxem 2000-2010
Powered by Community Server (Non-Commercial Edition), by Telligent Systems