Liberum Help Desk
The free, open source solution for the web-based help desk.

How to set up and install the Help Desk

rated by 0 users
Answered (Not Verified) This post has 0 verified answers | 21 Replies | 6 Followers

Top 500 Contributor
1 Posts
honoredfrank posted on 04-08-2009 4:48 AM

I am having problem setting up the database and installing the appliaction

This is the error message I get when setting up the data base.

 

Error Type:
Microsoft VBScript compilation (0x800A0401)
Expected end of statement
/help.desk/settings.asp, line 30, column 26
Application("DBType") = 3 "C:\inetpub\Help.Desk.db\helpdesk2000.mdb"

 

 

The database is stored in a folder call Help.Desk.db in the inetpub directory on my local server.

 

Please help me fix this problem, I can’t continue without fixing this.

 

My email addresses are frank.akyea@hb-gh.com, honoredfrank@yahoo.co.uk

 

Thank you.

All Replies

Top 25 Contributor
9 Posts

Please post the relevant few lines of code from settings.asp that define the path to your database file. This will be the section titled ACCESS SETTINGS.

Also need to know what OS you are running on.

At first glance, the error suggests you have a typo in the settings.asp or a permissions or path error.

Brad

Top 10 Contributor
46 Posts

Please dont put your database here C:\inetpub\Help.Desk.db\helpdesk2000.mdb

or someone will download it and havee all your information.

If you want a setup guide look here...

http://liberum.robatkinson.net/uploads/The_liberum_installation_guide.pdf

 

Top 10 Contributor
75 Posts

Application("DBType") = 3 "C:\inetpub\Help.Desk.db\helpdesk2000.mdb
This line is not valid vbscript syntax, it looks like your edit of the asp code wasn't successful.  Try again with a fresh copy of the file.

 

After the = you can't have a number and a space and a string.  That doesn't work.


Doug G

Top 500 Contributor
1 Posts

I'm getting a similar error. Any thoughts?

Error Type:
Microsoft VBScript compilation (0x800A0401)
Expected end of statement
/help.desk/settings.asp, line 14, column 45
sql="INSERT INTO testTable (myname) VALUES ("Request.Form("myname")")"

I'm not quite sure how to proceed.

Ken

 

Kenny Shapiro
Curator of Central Park tours.

Top 200 Contributor
2 Posts

Rob, that set up guide is perfect. Just what I needed to get me going again.

Not Ranked
1 Posts

Look at the setup guide.  It's pretty much perfect.

Not Ranked
1 Posts

that you for the guide! :D very useful !

Not Ranked
1 Posts

very detailed solution. thank you

Not Ranked
1 Posts

Yes got it dude...i was facing error at line 30,now it has resolved....it helped alot...thanks

Not Ranked
1 Posts

so that's why its having an error , I thought it was a bug or something, I tried to reinstall it but I used the same root.

Thanks Rob

Top 100 Contributor
3 Posts

Hi!

 

Can I got this guide? That link doesnt work anymore. Please help me.

Top 10 Contributor
46 Posts

http://mods.liberum.robatkinson.net/

Top 100 Contributor
3 Posts

Hi.

thx for link. Now i have problem with database.

Number: -2147467259 (0x80004005)
Source: Microsoft OLE DB Provider for ODBC Drivers
Description: [Microsoft][ODBC Driver Manager] Data source name not found and no default driver specified

Can you please help me, why i get this error. Is this base work ok?  maybe, do you have another base with some data inserted.

Please help me. Thx

 

 

Top 100 Contributor
3 Posts

this error i get when i logon with new user

Page 1 of 2 (22 items) 1 2 Next > | RSS
Copyright © Doug Luxem 2000-2010
Powered by Community Server (Non-Commercial Edition), by Telligent Systems